Scilab Home page | Wiki | Bug tracker | Forge | Mailing list archives | ATOMS | File exchange
Please login or create an account
Change language to: English - Français - Português - Русский

Please note that the recommended version of Scilab is 6.0.1. This page might be outdated.
See the recommended documentation of this function

Scilabヘルプ >> Xcos > Menu_entries

Menu_entries

Xcosエディタのメニューエントリ

内容

本節では Xcosエディタの全てのメニューエントリを簡単に 紹介します. 多くの要素が,マウスカーソルが ブロック,リンクまたはメインXcos ウインドウ にある時に右クリックして表示されるプルダウンメニューでも利用可能です.

Fileメニュー

  • ファイル:新規 (Ctrl+N)

    アクティブな編集Xcosウインドウに 空のダイアグラムを読み込む際には, Newメニューをクリックしてください. このメニューにより,新しいダイアグラムまたはパレットをオープンすることが できます.

  • ファイル:開く (Ctrl+O)

    保存されたブロックダイアグラムまたは パレットを有するXML (.zcos) またはバイナリのファイルを読み込む際には, Openメニューを選択してください. ダイアログボックスによりファイルを選択することができます.

  • ファイル:保存 (Ctrl+S)

    ダイアグラムを XML ファイルに保存するには, Save メニュー要素を選択してください.

    このメニュー要素を選択し, Saveまたは Save Asメニュー要素をクリックしていない場合, ダイアログによりディレクトリと拡張子を除くファイル名を選択することが できます. デフォルトの拡張子は, .zcosです.

  • ファイル:名前を付けて保存 (Ctrl+Shift+S)

    Select the Save As menu item to save the block diagram or palette in a file with a new name.

    A dialog box allows specifying a file name without the extension and a saving folder. The default extension is .zcos.

    The diagram takes the name of the file (without the extension).

  • ファイル:エクスポート (Ctrl+E)

    この要素は,カレントのXcosダイアグラムの 図をエキスポートする際に使用されます. エクスポートは, WBMP, GIF, HTML, JPEG, JPG, PNG, SVG または VML 形式で行われます.

  • ファイル:最近のファイル

    このメニューにより,最近開いたファイルに簡単にアクセスすることができます.

  • ファイル:印刷 (Ctrl+P)

    カレントのダイアグラムをプリンタで印刷します.

  • ファイル:閉じる (Ctrl+W)

    複数のダイアグラムがオープンされている場合, 「閉じる」によりカレントのダイアグラムが閉じられます. オープンされているダイアグラムが1つだけの場合, 「閉じる」によりXcosが閉じられ, (開かれている場合には)ビューポートおよびパレットも閉じられます.

  • ファイル:終了 (Ctrl+Q)

    複数のダイアグラムがオープンされている場合, 「終了」により Xcosが閉じられ, (開かれている場合には)ビューポートおよびパレットも閉じられます. このメニューにより全ての開かれているダイアグラムが 閉じられます.

編集メニュー

  • 編集:元に戻す (Ctrl+Z)

    直近の編集操作を取り消すには「元に戻す」を選択します.

  • 編集:やり直し (Ctrl+Y)

    取り消した直近の編集操作を再度実行するには, 「やり直し」メニューを選択します.

  • 編集:切り取り (Ctrl+X)

    選択されたオブジェクトをダイアグラムから削除し, オブジェクトがブロックの場合にクリップボードにコピーするには, 「切り取り」が使用されます.

  • 編集:コピー (Ctrl+C)

    選択されたオブジェクトを オブジェクトがブロックの場合にクリップボードにコピーするには, 「コピー」が使用されます.

  • 編集:貼り付け (Ctrl+V)

    「貼り付け」は, クリップボード上にあるオブジェクトをダイアグラムに 配置します.

  • 編集:削除 (Delete)

    ブロックまたはリンクを削除するには, まず「削除」メニューを選択した後, 選択するオブジェクトを順に(左ボタンで)クリックします. オブジェクトに結合された全てのリンクを削除した時点で, そのオブジェクトも同時に削除されます.

  • 編集:全て選択 (Ctrl+A)

    カレントのダイアグラムのブロックを全て選択します.

  • 編集:選択範囲を反転

    カレントの選択範囲を反転します.

  • 編集:ブロックパラメータ (Ctrl+B)

    選択されているブロックのブロック設定ウインドウを開きます. 設定は使用するブロックに依存します (設定の詳細についてはブロックヘルプを参照).

  • 編集:選択範囲をスーパーブロックに変換

    選択されたブロックをスーパーブロックに変換します.

表示メニュー

  • 表示:拡大 (Ctrl+Plus)

    このメニューを選択すると,ダイアグラムが10% 拡大されます.

  • 表示:縮小 (Ctrl+Minus)

    このメニューを選択すると,ダイアグラムが10% 縮小されます.

  • 表示:ビューをダイアグラムに合わせる

    このメニューを選択すると,ダイアグラムがカレントのウインドウの 大きさとなるよう調整されます.

  • 表示:通常 100%

    ダイアグラムがこの作業範囲に合うように 作業範囲の大きさを調整します.

  • 表示:パレットブラウザ

    パレットブラウザを開きます.

  • 表示:ダイアグラムブラウザ

    ダイアグラムのブロックの一覧を出力する ウインドウを表示し, ブロックのscs_m構造体に関する情報を出力します.

  • 表示:表示ポート

    表示ポートを表示します.表示ポートはカレントのダイアグラムの イメージです. この表示ポートにより,作業範囲をダイアグラムの一部に 移動することができます.

    上の図に,ダイアグラムの一部を拡大するビューポートの例を 示します.右側のxcosウインドウは,ダイアグラムの拡大された部分を 表示しています.

  • 表示:詳細

    ダイアグラムの選択されたブロックの一覧を示すウインドウを 表示し,これらのブロックのscs_m構造体に関する情報を出力します.

シミュレーションメニュー

  • シミュレーション:設定

    メインXcosウインドウにおいて, 設定メニューをクリックすると, 以下の積分パラメータを変更するための ダイアログボックスが起動します:

    • 積分終了時間 (積分はこの時間で終了します, この値は常に0を基準とします)

    • 実時間スケール(xcosの時間の単位を1秒に設定することにより 強制的にリアルタイムシミュレーションが実行されます)

    • 絶対許容誤差および相対許容誤差 (ソルバーのプロパティ)

    • 時間許容値 (ODEソルバーが連続状態量を更新する際に使用される 積分間隔の最小値)

    • 最大積分時間間隔(各ソルバーのコール時の時間間隔の最大値で エラーメッセージ"too many calls"が発生した場合はより小さな値と する必要があります)

    • ソルバ: 使用する数値ソルバーを選択. 常微分方程式 (ODE)ソルバまたは 代数微分方程式ソルバ(IDA)のどちらかを選択します. 使用するモデルがIDAソルバを必要とすると Xcos が検出した場合, Xcos はIDAソルバに自動的に切替える情報ボックスを 表示します.

    • 最大ステップサイズ: ソルバにより使用される最大時間ステップ. このパラメータは単調なシステム応答においてローカルな 特異性を探す際に有用です. この応答型の場合, 数値ソルバは, 計算時間を減らすために 自動的にステップサイズを増加させます. システムがこのようなケースであると思われる場合, このパラメータの値を減らしてください.

    • コンテキストを設定: 以下の説明を参照

    • デフォルト: このボタンはシミュレーションパラメータを工場値にリセットします.

    ソルバに関する詳細については, 参照 の節を参照ください.

  • 実行トレースとデバッグ

    Xcosをデバッグモードに設定します. This item opens the following dialog box in which you can choose the debugging mode. For more information, see the command scicos_debug

  • シミュレーション:コンテキスト設定

    When you select this menu item you obtain this dialog:

    You can enter here Scilab instructions for defining the symbolic Xcos parameters used in block definitions or to do whatever you want.

    These instructions will be evaluated each time the diagram is loaded. If you change the value of a symbolic Xcos parameters in the context, all the blocks that contains this symbolic parameter are updated when you click on OK. By example if you want to set the value of gain of several blocks to a value which depends on a single value, you can proceed like this :

    1. We have three GAINBLK_f blocks, open the Set context dialog and writes the symbolic variables:

      A = 1.5;
      B = 2*A;
      C = 3*A;

    2. Then, open successively each block parameters dialog and set for the gain value the name of required symbolic value, here A,B and C.

  • シミュレーション:コンパイル

    ブロックダイアグラムをコンパイルする際には 「コンパイル」メニューを選択します. (実行メニューによる)各シミュレーションの開始前に必要に応じて実行前に 自動的にコンパイルが行われるため,このメニューは使用されることはありません. 通常,新たなコンパイルはシステムパラメータおよび内部状態量が 修正された場合でも不要です. しかしながら,いくつかのケースでは, これらの修正が正常に更新されない場合があり, 再開または継続の前にマニュアルでコンパイルを行うことが 必要となる可能性があります.

    このようなケースが見つかった場合には,報告してください. Scilabに関するバグと希望をレポートしてください.

  • Simulate:Modelica の初期化

    このメニュー要素は, Modelicaコンパイラの専用ダイアログをオープンします. このダイアログでは,モデルの内容を確認でき, Kinsol, Ida, Fsolve, Optim, Nelder Mead および Hompack ソルバ からソルバを選択することもできます.

  • シミュレーション:開始

    シミュレーションを開始するには開始メニューを選択します. システムがシミュレーション済みの場合には, シミュレーションの継続,再開または終了を選択する ダイアログボックスが開きます.

  • シミュレーション:停止

    "停止"ボタンを選択することによりシミュレーションを中断することが でき,任意のブロックパラメータを変更して,新しい値で シミュレーションを継続することができます.

フォーマットメニュー

  • フォーマット:回転 (Ctrl+R)

    回転では,ブロックを左に 90°回転することができます. 回転は選択された全ブロックに適用されます.

  • フォーマット:反転 (Ctrl+F)

    側面に配置されたブロックの(通常の)入力および出力の位置を反転する 際には,まず「反転」メニューを選択した後, 選択するブロックをクリックします. これにより,左から右に番号がふられている 入力および出力イベントポートの順番や位置は変更されません.

  • フォーマット:ミラー (Ctrl+M)

    ブロックの左右に設定した(標準)入力および出力の位置を反転する際には, ブロックを選択し, Mirrorメニュー要素を選択します. これは, 上から下に番号が付けられた入力および出力ポートの順番および 位置には影響しません. ミラーリングは選択された全ブロックに作用します.

  • フォーマット:影を表示/非表示

    このメニューにより選択されたブロックの 3次元表示および関連するパラメータを選択することができます.

  • フォーマット:ブロックの整列

    複数のブロックを選択した場合, 垂直方向(上,下,中央)および水平方向(左,右,中心)にこれらを整列させることができます.

  • フォーマット: 境界の色

    このメニューにより境界の色を変更できます.

  • フォーマット:線の色

    このメニューにより線の色を変更できます.

  • フォーマット:結合方法

    このメニューにより結合の形式を選択できます:

    まず,リンクを選択,適当なメニュー要素を選択または ショートカット(H), S, V) を使用します. 以下に得られる結果のリストを示します.

    • 水平 (H)

    • 直線 (S)

    • 垂直 (V)

  • フォーマット:ダイアグラムの背景

    このメニューにより背景の色を変更できます.

  • フォーマット:グリッド

    このメニューによりグリッドを有効/無効にできます. グリッドにより,作業領域でブロックを配置するのは容易になります.

ツールメニュー

  • ツール:コード生成

    このメニューにより,離散時間スーパーブロックに関連するシミュレーションコードを 生成することができます. コード生成は,このメニューを選択した後, 指定するスーパーブロックを選択することにより行ないます. スーパーブロックが必要な条件を満たす場合, ブロック名,生成されたファイルを置くディレクトリおよび リンカにより指定されたオプションのライブラリを入力する ダイアログボックスがポップアップします. これらの情報を指定すると, コードが生成され,コンパイル,Scilabとリンクされます. スーパーブロックは生成されたコードを実装する 新しいブロックで自動的に置換されます. この後,修正されたダイアグラムを実行することができます. スタンドアロン実行用のコードも生成されます.

ヘルプメニュー

  • ヘルプ:Xcosヘルプ (F1)

    このメニューはXcosヘルプブラウザをオープンします.

  • ヘルプ:ブロックヘルプ

    特定のXcosオブジェクト(ブロック)のヘルプを取得するには, まずオブジェクト(ブロック)を選択した後, このヘルプメニュー項目をクリックします.

  • ヘルプ:Xcosデモ

    このデモメニューによりXcosダイアグラムのいくつかの例を オープンすることができます.

  • ヘルプ:Xcosについて

    Xcosの現在のバージョンおよびいくつかの有用な情報を出力します.

参照

  • scicos_debug — Set the level of the Scicos debugging
  • ode — 常微分方程式ソルバ
  • dassl — 微分代数方程式
Scilab Enterprises
Copyright (c) 2011-2017 (Scilab Enterprises)
Copyright (c) 1989-2012 (INRIA)
Copyright (c) 1989-2007 (ENPC)
with contributors
Last updated:
Thu Oct 02 13:58:35 CEST 2014