Scilab Home page | Wiki | Bug tracker | Forge | Mailing list archives | ATOMS | File exchange
Please login or create an account
Change language to: English - Português - Русский - 日本語

Please note that the recommended version of Scilab is 6.0.0. This page might be outdated.
See the recommended documentation of this function

Aide de Scilab >> Xcos > Entrées de menu

Entrées de menu

Entrées de menu de l'éditeur Xcos

Contenu

Cette section présente brièvement toutes les entrées de menu de l'éditeur Xcos. Beaucoup d'items sont également disponibles dans les menus contextuels affichés par un clic droit quand le curseur de souris est sur un bloc, une liaison ou dans la fenêtre principale de Xcos window.

Menu Fichier

  • Fichier : Nouveau schéma (Ctrl+N)

    En cliquant sur l'item Nouveau schéma un schéma vide est chargé dans une nouvelle fenêtre d'édition de schéma Xcos. Avec ce menu, vous pouvez ouvrir un nouveau schéma ou une nouvelle palette.

    Le schéma Xcos courant n'est pas affecté.

  • Fichier : Ouvrir (Ctrl+O)

    Sélectionnez l'item Ouvrir pour charger un fichier XML (.zcos) ou binaire (.cos) contenant un schéma-bloc ou une palette. La commande ouvre une boîte de dialogue qui vous permet de choisir un dossier et un fichier.

  • Fichier : Enregistrer (Ctrl+S)

    Sélectionnez l'item de menu Enregistrer pour sauver le schéma-bloc dans un fichierXML.

    Si vous choisissez cet item sans jamais avoir cliqué sur l'item Enregistrer ou l'item Enregistrer sous, un dialogue vous permet de choisir un répertoire et de spécifier un nom de fichier sans extension. L'extension par défaut est .zcos

    Le schéma prend le nom du fichier (sans l'extension).

  • Fichier : Enregistrer sous (Ctrl+Maj+S)

    Sélectionnez l'item Enregistrer sous pour sauver le schéma bloc ou la palette avec un nouveau nom.

    Un dialogue permet de spécifier un nom de fichier et un dossier de sauvegarde. Comme nous l'avons dit ci-dessus ne spécifiez pas d'extension. L'extension par défaut est .zcos.

    Le schéma prend le nom du fichier (sans l'extension).

  • Fichier : Exporter (Ctrl+E)

    Cet item est utilisé pour exporter une image du schéma Xcos courant. L'exportation peut être faîte aux formats WBMP, GIF, HTML, JPEG, JPG, PNG, SVG ou VML.

  • Fichier : Fichiers récents

    A travers ce menu, vous avez un accès rapide aux fichiers récemment ouverts.

  • Fichier : Imprimer (Ctrl+P)

    Imprime le schéma courant sur une imprimante.

  • Fichier : Fermer (Ctrl+W)

    Si plusieurs schémas sont ouverts, l'action Fermer ferme le schéma courant. Si un seul schéma est ouvert, l'action Fermer ferme Xcos. Les fenêtres auxiliaires telles que zone d'affichage, palettes, etc. sont également fermées si nécessaire.

  • Fichier : Quitter (Ctrl+Q)

    L'action Quitter ferme Xcos. Les fenêtres auxiliaires telles que zone d'affichage, palettes, etc sont également fermées si nécessaire.

Menu Édition

  • Édition : Défaire (Ctrl+Z)

    Sélectionnez l'item Défaire pour annuler la dernière opération d'édition.

  • Édition : Rétablir (Ctrl+Y)

    Sélectionnez l'item Rétablir pour rétablir la dernière opération d'édition annulée.

  • Édition : Couper (Ctrl+X)

    Couper est utilisé pour supprimer les objets sélectionnés du schéma et en garder une copie dans le presse-papier. Quand vous effacez un bloc, toutes les liaisons qui lui sont connectées sont elles aussi effacées.

  • Édition : Copier (Ctrl+C)

    Copier est utilisé pour placer une copie des objets sélectionnés dans le presse-papier.

  • Édition : Coller (Ctrl+V)

    Coller place le contenu du presse-papier dans le schéma courant.

  • Édition : Supprimer (Suppr)

    Pour effacer des blocs ou des liaisons, sélectionnez les objets à effacer puis l'item Supprimer. Quand vous effacez un bloc, toutes les liaisons qui lui sont connectées sont elles aussi effacées.

  • Édition : Tout sélectionner (Ctrl+A)

    Sélectionne tous les blocs du schéma courant.

  • Édition : Inverser la sélection

    Inverse la sélection courante.

  • Édition : Paramètres de bloc (Ctrl+B)

    Ouvre le dialogue de configuration du bloc sélectionné. La configuration dépend du bloc utilisé (voir l'aide du bloc pour obtenir plus d'information sur sa configuration).

  • Édition : Zone vers superbloc

    Convertit une sélection de blocs en un superbloc.

Menu Affichage

  • Affichage : Zoom avant (Ctrl+Pavé numérique Plus)

    Quand vous sélectionnez cet item la vue du schéma est agrandie d'un facteur de 10%.

  • Affichage : Zoom arrière (Ctrl+Pavé numérique Moins)

    Quand vous sélectionnez cet item, la vue du schéma est réduite d'un facteur de 10%.

  • Affichage : Ajuster le diagramme à la vue

    Quand vous sélectionnez cet item la vue du schéma est ajustée à la taille de la fenêtre courante.

  • Affichage : Normal 100%

    Dimensionne les composants du diagramme à leurs dimensions par défaut.

  • Affichage : Navigateur de palettes

    Ouvre le navigateur de palette.

  • Affichage : Navigateur de diagrammes

    Affiche une fenêtre qui liste les propriétés globales du schéma et de tous les objets qu'il contient (blocs et liaisons). Il présente le contenu de la structure scs_m du schéma.

  • Affichage : Aperçu

    Affiche la vue Aperçu. Cette fenêtre est une image complète du schéma courant. Avec la vue Aperçu, vous pouvez déplacer l'aire de travail affichée sur une partie du schéma. Vous pouvez agrandir ou réduire la vue du schéma.

    Ci-dessus, vous avez un exemple de la vue Aperçu incluse dans la fenêtre Xcos utilisée pour agrandir une partie du schéma. Sur la gauche, la fenêtre d'édition présente la partie agrandie du schéma.

  • Affichage : Détails

    Affiche une fenêtre par bloc sélectionné qui liste les propriétés du bloc. Il présente sous forme d'arbre le contenu de la structure scs_m du bloc

Menu Simulation

  • Simulation : Configurer

    Dans la fenêtre principale de Xcos, Un clic sur l'item de menu Configurer invoque le dialogue ci-dessous qui vous permet de modifier les paramètres d'intégration (simulation):

    • Temps final d'intégration : l'intégration (la simulation) finit à cet instant, elle démarre toujours à 0.

    • Mise à l'échelle temps réel : force une simulation temps réel en plaçant l'unité de temps de simulation Xcos à 1 seconde.

    • Tolérances absolue et relative : propriétés du du solveur.

    • Tolérance de temps : le plus petit intervalle de temps pour lequel le solveur ode est utilisé pour mettre à jour les états continus.

    • Intervalle max de temps d'intégration : l'intervalle maximal de temps entre chaque appel au solveur. il doit être réduit si le message "Beaucoup trop d'appels" est rencontré.

    • Solveur : choix du solveur numérique à utiliser. Vous avez le choix entre un solveur d'équations différentielles ordinaires (ODE) et un solveur d'équations différentielles algébriques (IDA). Si Xcos détecte que votre modèle requiert un solveur IDA, Xcos affiche un message d'information pour son basculement automatique vers le solveur IDA.

    • Taille de pas maximum : la valeur maximale d'un pas de temps calcul pris par le solveur. Ce paramètre est utile pour chercher les singularités localisées dans une réponse monotone d'un système. Pour ce type réponse, le solveur accroît automatiquement la valeur du pas pour diminuer le temps global de calcul. Si vous pensez que votre système est dans ce cas, réduisez la valeur de ce paramètre.

    • Modifier le contexte : voir l'explication ci-dessous.

    • Standard : ce bouton remet les paramètres de simulation à leurs valeurs usine.

    Pour plus d'information sur les solveurs, rendez-vous à la section Voir aussi.

  • Trace d'exécution et de débogage

    Met Xcos en mode débogage. Pour plus d'informations, voir la commande scicos_debug

  • Simulation : Modifier le contexte

    Quand vous sélectionnez cet item de menu vous obtenez ce dialogue :

    Vous pouvez entrer des instructions Scilab pour définir des paramètres symboliques Xcos utilisés dans les définitions de bloc ou faire tout autre chose.

    Ces instructions seront évaluées à chaque chargement du schéma. Si vous changez la valeur d'un paramètre symbolique Xcos dans le contexte, tous les blocs qui le contiennent sont mis à jour quand vous cliquez sur OK. Par exemple si vous voulez mettre la valeur de gain de plusieurs blocs à une valeur dépendant d'une seule valeur, vous pouvez procéder comme suit

    1. Nous avons trois blocs GAINBLK_f, ouvrez le dialogue Modifier le contexte et écrivez vos variables symboliques :

      A = 1.5;
      B = 2*A;
      C = 3*A;

    2. Ensuite, ouvrez successivement chaque boîte de dialogue de paramètres de bloc et inscrivez pour la valeur de gain le nom de la valeur symbolique, ici A, B, et C.

  • Simulation : Compiler

    Sélectionnez l'item Compiler pour compiler le schéma-bloc. Cet item n'a jamais besoin d'être utilisé puisque la compilation est effectuée, si nécessaire, avant le début de chaque simulation (item de menu Démarrer).

    Normalement, une nouvelle compilation n'est pas utile si seuls les paramètres et les états internes sont modifiés. Dans quelques cas cependant, ces modifications ne sont pas correctement mises à jour et une compilation peut être nécessaire avant de Redémarrer ou de Continuer.

    Si vous rencontrez une telle situation, veuillez s'il vous plaît, nous la signaler. Rapport de bogues et d'amélioration de Scilab

  • Simulation : Initialisation de Modelica

    Cet item ouvre un dialogue spécifique pour le compilateur Modelica où vous pouvez voir les composants de votre modèle et également sélectionner un solveur parmi les solveurs Kinsol, Ida, Fsolve, Optim, Nelder Mead et Hompack.

  • Simulation : Démarrer

    Sélectionnez l'item Démarrer pour lancer la simulation. Si le système a déjà été simulé, un dialogue est affiché dans lequel vous pouvez choisir entre Continuer, Redémarrer ou Terminer la simulation.

  • Simulation : Stop

    Vous pouvez interrompre la simulation en cliquant sur l'item Stop ou sur le bouton de la barre d'outils. Vous pouvez modifier les paramètres de bloc et continuer la simulation avec les nouvelles valeurs.

Menu Format

  • Format : Rotation (Ctrl+R)

    Rotation permet de tourner un bloc vers la gauche d'un angle de 90°. La rotation affecte tous les blocs sélectionnés.

  • Format : Pivoter (Ctrl+F)

    Pour inverser les positions des entrées et sorties d'événements placées en haut et en bas d'un bloc, sélectionnez un bloc et l'item Flip. Ceci n'affecte ni l'ordre ni la position des ports d'entrée et de sortie d'événement qui sont numérotés de droite à gauche. Le pivotement affecte tous les blocs sélectionnés.

  • Format: Miroir (Ctrl+M)

    Pour inverser les positions des entrées et sorties régulières placées sur sa gauche et sur sa droite, sélectionnez un bloc et l'item Miroir Ceci n'affecte ni l'ordre, ni la position des ports d'entrée et de sortie réguliers qui sont numérotés de haut en bas. Le miroir affecte tous les blocs sélectionnés.

  • Format : Afficher/Cacher l'ombre

    L'item permet de sélectionner l'aspect 3D des blocs sélectionnés.

  • Format : Aligner les blocs

    Quand vous sélectionnez plusieurs blocs, il est possible de les aligner sur l'axe horizontal (Haut, Bas et Milieu) ou sur l'axe vertical (Gauche, Droite et Centre).

  • Format : Couleur de la bordure

    L'item permet de changer la couleur des bords des blocs sélectionnés.

  • Format : Couleur de remplissage

    L'item permet de changer la couleur de remplissage des blocs sélectionnés.

  • Format : Style de liaison

    L'item permet de modifier le style d'une liaison.

    • Horizontal

    • Direct

    • Vertical

  • Format : Fond du schéma...

    L'item permet de changer la couleur de fond du schéma.

  • Format : Grille

    L'item permet d'activer/désactiver la grille. Avec la grille, le placement des blocs et des liaisons est plus facile et vous obtenez un schéma plus lisible.

Menu Outils

  • Tools : Génération de code

    Ce menu permet de générer le code de simulation associé avec à un Super bloc en temps discret. La génération de code est obtenue simplement en sélectionnant le Super bloc et ensuite ce menu.

    Si le Super bloc satisfait les conditions requises, un dialogue est affiché qui demande un nom de bloc, le répertoire où placer les fichiers générés et les librairies optionnelles requises par l'éditeur de lien. Une fois cette information donnée, le code est généré, compilé et lié avec Scilab.

    Le Super bloc est remplacé automatiquement par un nouveau bloc qui implémente le code généré. Ensuite, il est possible de simuler le schéma modifié. Le code pour une utilisation autonome est également généré.

Menu ?

  • Aide : Aide Xcos (F1)

    Ce menu ouvre le navigateur d'aide sur la section Xcos.

  • Aide : Aide du bloc

    Pour obtenir de l'aide sur un bloc Xcos, sélectionnez le bloc cliquez ensuite sur cet item.

  • Aide : Démos Xcos

    L'item Démos Xcos permet d'ouvrir plusieurs exemples de schémas Xcos.

  • Aide : A propos de Xcos

    L'item About Xcos affiche la version courante de Xcos dans un dialogue.

See Also

  • scicos_debug — Set the level of the Scicos debugging
  • ode — solveur d'équations différentielles ordinaires
  • dassl — differential algebraic equation

Auteurs

  • DIGITEO
  • Bernard DUJARDIN - Contributeur
Scilab Enterprises
Copyright (c) 2011-2017 (Scilab Enterprises)
Copyright (c) 1989-2012 (INRIA)
Copyright (c) 1989-2007 (ENPC)
with contributors
Last updated:
Thu Oct 02 13:54:44 CEST 2014