Scilab Home page | Wiki | Bug tracker | Forge | Mailing list archives | ATOMS | File exchange
Please login or create an account
Change language to: English - Português - Русский - 日本語

Please note that the recommended version of Scilab is 6.0.0. This page might be outdated.
See the recommended documentation of this function

Aide de Scilab >> Link dynamique/incremental > Supported and compatible compilers

Supported and compatible compilers

supported and compatible compilers by Scilab

Scilab supported and compatible compilers

Some features of Scilab require that you have a third-party compiler installed on your system.

Windows

-- Visual studio C++ 2005, 2008, 2010, 2012 Professionnal 32 and 64 bits

-- Visual studio C++ 2012 Express Edition (available at no charge)

More information is available on Scilab Wiki.

-- Intel Fortran 9, 10, 11, XE 2011, XE 2012

-- LCC-Win32 requires to install a ATOMS module:

atomsInstall('lcc_windows'); atomsLoad('lcc_windows');

-- MinGW requires to install a ATOMS module:

atomsInstall('mingw'); atomsLoad('mingw');

GNU/Linux

On GNU/Linux, GNU compilers (gcc, g++ and gfortran) are packaged in all distributions.

While they are not official supported, Scilab supports LLVM/clang and Intel compilers.

Mac OS X

Apple's development environment for OS X, Xcode, is available from Apple at no charge.

See Also

Scilab Enterprises
Copyright (c) 2011-2017 (Scilab Enterprises)
Copyright (c) 1989-2012 (INRIA)
Copyright (c) 1989-2007 (ENPC)
with contributors
Last updated:
Thu Oct 02 13:54:44 CEST 2014