Scilab Home page | Wiki | Bug tracker | Forge | Mailing list archives | ATOMS | File exchange
Please login or create an account
Change language to: English - Français - Português -

Please note that the recommended version of Scilab is 6.0.1. This page might be outdated.
See the recommended documentation of this function

Scilab help >> Xcos > Menu_entries

Menu_entries

エディタのメニューエントリ

Fileメニュー

  • ファイル:新規

    アクティブな編集xcosウインドウに空のダイアグラムを読み込む際には, 「新規ダイアグラム」メニューをクリックしてください. ウインドウの前の内容が保存されていない場合は,失われます. このメニューにより,新しいダイアグラムまたはパレットをオープンすることが できます.

  • ファイル:開く (Ctrl+o)

    保存されたブロックダイアグラムまたは パレットを有するアスキーまたはバイナリのファイルを読み込む際には, 「開く」メニューを選択してください. ダイアログボックスによりファイルを選択することができます.

  • ファイル:保存 (Ctrl+s)

    前の「名前を付けて保存」で選択済みのバイナリファイルに ブロック図を保存する際には,「保存」メニューを選択してください. このメニュー項目を選択した時点で, まだ「名前を付けて保存」メニューをクリックしていない場合は, カレントのディレクトリに"window_name".cosという名前で保存されます. ただし,"window_name"はウインドウの最上部に表示されている ウインドウ名(通常は「無題」または「スーパーブロック」)です. .cos バイナリファイルは計算機に依存しません.

  • ファイル:名前を付けて保存 (Ctrl+Shift+s)

    ブロックダイアグラムまたはパレットをファイルに保存する際には, 「名前を付けて保存」メニューを選択してください. ダイアログボックスによりファイルを選択することができます. ファイルの拡張子は .cos または .cosfとする必要があります. ダイアグラムはファイル名(拡張子無し)を指定します. 拡張子が".cosf"の場合,バイナリではなく アスキー形式で保存されます. 整形を伴なう保存は通常の保存よりも時間を要します.

  • ファイル:エクスポート (Ctrl+e)

    このメニューは,カレントのxcosダイアグラムの図をエキスポートする 際に使用されます. エキスポートは,ポストスクリプト形式に直接行うか,または まずグラフィックウインドウをエキスポートしたあとに Scilabが出力可能な任意の形式にエキスポートします.

  • ファイル:最近のファイル

    このメニューにより,最近開いたファイルに簡単にアクセスすることができます.

  • ファイル:印刷 (Ctrl+p)

    カレントのダイアグラムをプリンタで印刷します.

  • ファイル:閉じる (Ctrl+w)

    複数のダイアグラムがオープンされている場合, 「閉じる」によりカレントのダイアグラムが閉じられます. オープンされているダイアグラムが1つだけの場合, 「閉じる」によりxcosが閉じられ, (開かれている場合には)ビューポートおよびパレットも閉じられます.

  • ファイル:終了 (Ctrl+q)

    複数のダイアグラムがオープンされている場合, 「終了」により xcosが閉じられ, (開かれている場合には)ビューポートおよびパレットも閉じられます. このメニューにより全ての開かれているダイアグラムが 閉じられます.

編集メニュー

  • 編集:元に戻す (Ctrl+z)

    直近の編集操作を取り消すには「元に戻す」を選択します.

  • 編集:やり直し (Ctrl+y)

    取り消した直近の編集操作を再度実行するには, 「やり直し」メニューを選択します.

  • 編集:切り取り (Ctrl+x)

    選択されたオブジェクトをダイアグラムから削除し, オブジェクトがブロックの場合にクリップボードにコピーするには, 「切り取り」が使用されます.

  • 編集:コピー (Ctrl+c)

    選択されたオブジェクトを オブジェクトがブロックの場合にクリップボードにコピーするには, 「コピー」が使用されます.

  • 編集:貼り付け (Ctrl+v)

    「貼り付け」は, クリップボード上にあるオブジェクトをダイアグラムに 配置します.

  • 編集:削除 (Delete)

    ブロックまたはリンクを削除するには, まず「削除」メニューを選択した後, 選択するオブジェクトを順に(左ボタンで)クリックします. オブジェクトに結合された全てのリンクを削除した時点で, そのオブジェクトも同時に削除されます.

  • 編集:全て選択 (Ctrl+a)

    カレントのダイアグラムのブロックを全て選択します.

  • 編集:選択範囲を反転

    カレントの選択範囲を反転します.

  • 編集:ブロックパラメータ (Ctrl+b)

    選択されているブロックのブロック設定ウインドウを開きます.

  • 編集:選択範囲をスーパーブロックに変換

    選択されたブロックをスーパーブロックに変換します.

表示メニュー

  • 表示:拡大 (Ctrl+plus)

    このメニューを選択すると,ダイアグラムが10%拡大されます.

  • 表示:縮小 (Ctrl+minus)

    このメニューを選択すると,ダイアグラムが10%縮小されます.

  • 表示:ビューをダイアグラムに合わせる

    このメニューを選択すると,ダイアグラムがカレントのウインドウの 大きさとなるよう調整されます.

  • 表示:通常 100%

    ダイアグラムがこの作業範囲に合うように 作業範囲の大きさを調整します.

  • 表示:パレットブラウザ

    パレットブラウザを開きます.

  • 表示:ダイアグラムブラウザ

    ダイアグラムのブロックの一覧を出力する ウインドウを表示し, ブロックのscs_m構造体に関する情報を出力します.

  • 表示:表示ポート

    表示ポートを表示します.表示ポートはカレントのダイアグラムの イメージです. この表示ポートにより,作業範囲をダイアグラムの一部に 移動することができます.

    上の図に,ダイアグラムの一部を拡大するビューポートの例を 示します.右側のxcosウインドウは,ダイアグラムの拡大された部分を 表示しています.

  • 表示:詳細

    ダイアグラムの選択されたブロックの一覧を示すウインドウを 表示し,これらのブロックのscs_m構造体に関する情報を出力します.

シミュレーションメニュー

  • シミュレーション:設定

    メインXcosウインドウにおいて, 設定メニューをクリックすると, 以下の積分パラメータを変更するための ダイアログボックスが起動します:

    • 積分終了時間 (積分はこの時間で終了します, この値は常に0を基準とします)

    • 実時間スケール(xcosの時間の単位を1秒に設定することにより 強制的にリアルタイムシミュレーションが実行されます)

    • 絶対許容誤差および相対許容誤差 (ソルバーのプロパティ)

    • 時間許容値 (ODEソルバーが連続状態量を更新する際に使用される 積分間隔の最小値)

    • 最大積分時間間隔(各ソルバーのコール時の時間間隔の最大値で エラーメッセージ"too many calls"が発生した場合はより小さな値と する必要があります)

    • ソルバー (使用する数値ソルバーを選択), ステップの大きさの最大値(ソルバーにより設定される時間ステップの最大値)

  • 実行トレースとデバッグ

    Xcosをデバッグモードに設定し. ダイアグラムのデバッグを できるようにします.

  • シミュレーション:コンテキスト設定

    このメニューを選択すると, ブロック定義または任意の処理で使用されるシンボリックなXcosパラメータ を定義するための Scilab命令を入力するダイアログがオープンされます. これらの命令は,ダイアグラムが読み込まれる度に評価されます. コンテキストのシンボリックなXcosパラメータの値を変更した場合, 全てのブロックが更新されます(evalが実行されます).

  • シミュレーション:コンパイル

    ブロックダイアグラムをコンパイルする際には 「コンパイル」メニューを選択します. (実行メニューによる)各シミュレーションの開始前に必要に応じて実行前に 自動的にコンパイルが行われるため,このメニューは使用されることはありません. 通常,新たなコンパイルはシステムパラメータおよび内部状態量が 修正された場合でも不要です. しかしながら,いくつかのケースでは, これらの修正が正常に更新されない場合があり, 再開または継続の前にマニュアルでコンパイルを行うことが 必要となる可能性があります. このようなケースが見つかった場合には,報告してください.

  • シミュレーション:開始

    シミュレーションを開始するには開始メニューを選択します. システムがシミュレーション済みの場合には, シミュレーションの継続,再開または終了を選択する ダイアログボックスが開きます.

  • シミュレーション:停止

    "停止"ボタンを選択することによりシミュレーションを中断することが でき,任意のブロックパラメータを変更して,新しい値で シミュレーションを継続することができます.

フォーマットメニュー

  • フォーマット:回転 (Ctrl+r)

    「回転」によりブロックを左に回転できます. ブロックが左に回転する度に,角度が45度増えます. ブロックを選択しなかった場合または複数のブロックを選択した場合, マウスポインタの下のブロックが回転されます.

  • フォーマット:反転 (Ctrl+f)

    側面に配置されたブロックの(通常の)入力および出力の位置を反転する 際には,まず「反転」メニューを選択した後, 選択するブロックをクリックします. これにより,左から右に番号がふられている 入力および出力イベントポートの順番や位置は変更されません.

  • フォーマット:影を表示/非表示

    このメニューにより選択されたブロックの 3次元表示および関連するパラメータを選択することができます.

  • フォーマット:ブロックの整列

    複数のブロックを選択した場合, 垂直方向(上,下,中央)および水平方向(左,右,中心)にこれらを整列させることができます.

  • フォーマット: 境界の色

    このメニューにより境界の色を変更できます.

  • フォーマット:線の色

    このメニューにより線の色を変更できます.

  • フォーマット:結合方法

    このメニューにより結合の形式を選択できます:

    • 水平

    • 直線

    • 垂直

  • フォーマット:ダイアグラムの背景

    このメニューにより背景の色を変更できます.

  • フォーマット:グリッド

    このメニューによりグリッドを有効/無効にできます. グリッドにより,作業領域でブロックを配置するのは容易になります.

ツールメニュー

  • ツール:コード生成

    このメニューにより,離散時間スーパーブロックに関連するシミュレーションコードを 生成することができます. コード生成は,このメニューを選択した後, 指定するスーパーブロックを選択することにより行ないます. スーパーブロックが必要な条件を満たす場合, ブロック名,生成されたファイルを置くディレクトリおよび リンカにより指定されたオプションのライブラリを入力する ダイアログボックスがポップアップします. これらの情報を指定すると, コードが生成され,コンパイル,Scilabとリンクされます. スーパーブロックは生成されたコードを実装する 新しいブロックで自動的に置換されます. この後,修正されたダイアグラムを実行することができます. スタンドアロン実行用のコードも生成されます.

ヘルプメニュー

  • ヘルプ:Xcosヘルプ

    このメニューはヘルプブラウザをオープンします.

  • ヘルプ:ブロックヘルプ

    特定のXcosオブジェクト(ブロック)のヘルプを取得するには, まずオブジェクト(ブロック)を選択した後, このヘルプメニュー項目をクリックします.

  • ヘルプ:Xcosデモ

    このデモメニューによりXcosダイアグラムのいくつかの例を オープンすることができます.

  • ヘルプ:Xcosについて

    Xcosの現在のバージョンおよびいくつかの有用な情報を出力します.

Scilab Enterprises
Copyright (c) 2011-2017 (Scilab Enterprises)
Copyright (c) 1989-2012 (INRIA)
Copyright (c) 1989-2007 (ENPC)
with contributors
Last updated:
Thu Mar 03 11:01:00 CET 2011